"Follow minor planet" silently fails, FITS format issue?

Image processing, astrometry, photometry, etc.
Post Reply
municher
Posts: 2
Joined: 08 Apr 2020, 14:13

"Follow minor planet" silently fails, FITS format issue?

Post by municher » 08 Apr 2020, 15:06

Hello,

With images captured from an older ATIK 314L through the older Artemis Capture software the "follow minor planet" functionality in AA5 and AA7 demo silently fails.
From what i gather the basis here is to be able to read the time and date of the observation properly from the files.
Even though that info apparently does exist in the FITS header, i assume it is incorrectly formatted:
...
INSTRUME= 'ATIK-314L: fw rev 3.01'
EXPTIME = 20.015
DATE-OBS= '2020-04-07T21:52:22'
...

The value apparently extends to far to the right, being padded with spaces on the left. Is this something AA should be able to read?

Best regards,
Martin

municher
Posts: 2
Joined: 08 Apr 2020, 14:13

Re: "Follow minor planet" silently fails, FITS format issue?

Post by municher » 08 Apr 2020, 15:19

I manually edited a few files, removing the leading blanks. Now the follow minor planet works.

But i have hundreds of such files, so a tool is neaded to correct them...

Regards, Martin

fabdev
Posts: 221
Joined: 03 Dec 2018, 21:43

Re: "Follow minor planet" silently fails, FITS format issue?

Post by fabdev » 08 Apr 2020, 15:42

Hello,
DATE-OBS is a string, so it can extend beyond the 30th character.
But just like all FITS strings it must begin with characther < ' > on the 11th character.
You may compare it with the one created by the Camera Simulator.

If you like, send me an image by email, maybe a solution is possible.
Fabio.

Post Reply